Skip to main content
Question

Event Stats Dashboard for time > 92 days

  • March 18, 2026
  • 1 reply
  • 46 views

Forum|alt.badge.img+2

Hi,

 

I want to get a report using the dashboards for a time period exceeding 92 days that is currently permitted for stats dashboards.

 

i cant do this using a UDM search result since the requirement i have is to only get the latest login which is not possible through the CSV file that i can get by doing a udm search.

 

The query i need is this:

events:
$e.metadata.log_type = <logtypevalue>
$e.metadata.product_log_id = <value>
$e.principal.user.userid = $userid
$userid != ""
$e.principal.user.group_identifiers = $group

$seconds = $e.metadata.event_timestamp.seconds
$date = timestamp.get_date($e.metadata.event_timestamp.seconds)

match:
$userid, $group

outcome:
$event_count = count($e.metadata.id)
$Last_login_date = timestamp.get_timestamp(max($e.metadata.event_timestamp.seconds) + 19800) //adding +5.30 in minutes to utc time

order:
$userid asc

 

 

Is there a way i can do this.

1 reply

kentphelps
Community Manager
Forum|alt.badge.img+12
  • Community Manager
  • April 3, 2026

Take a look at this blog on using UDM searches in dashboard and see if you can’t take your query (with match and outcome) and pin it to a dashboard to bypass the 92-day UI search limit: