Skip to main content
Solved

How to use MANDIANT_ACTIVE_BREACH_IOC in custom rule

  • February 9, 2026
  • 5 replies
  • 200 views

lalji_d
Forum|alt.badge.img+2

Hello, 

I'm currently developing a custom detection rule and I'm looking to incorporate MANDIANT_ACTIVE_BREACH_IOC data into it.
I would appreciate any guidance or best practices on how to effectively use this data within my rules. Specifically, how can I leverage the attributes associated with MANDIANT_ACTIVE_BREACH_IOC  for domains and how use that to enhance threat detection? Any examples or experiences would be greatly appreciated.

Right now I have something like this rule for test :

rule test_rule {
  meta:
    author          = "Test"
    description     = "Mandiant IOC Feed in rule"
    yara_version    = "YL2.0"

  events:

    $e.metadata.event_type = "NETWORK_CONNECTION"
    $e.target.hostname = $ioc 

    $context_graph.graph.entity.hostname  = $ioc 
    $context_graph.graph.metadata.product_name = "MANDIANT_ACTIVE_BREACH_IOC"
    $context_graph.graph.metadata.entity_type = "DOMAIN_NAME"
    $context_graph.graph.metadata.source_type = "GLOBAL_CONTEXT"

  match:
    $ioc over 2h

  outcome:
    $target_hostname = array_distinct($ioc)

  condition:
    $e and $context_graph
}

 

Getting no results on testing this detection rule but for the same duration I can see curated ATI rule getting triggered for some domains.

Best answer by lalji_d

Hello ​@lalji_d, as per this answer by ​@cmorris on another post about this IOC feed, you cannot use it in custom rules :

You're welcome ​@desertfalcon. You are not able to use SIEM search or custom detection rules for this feed.

Thanks ​@chrisd2 !

5 replies

chrisd2
Forum|alt.badge.img+9
  • Bronze 5
  • February 14, 2026

Hello ​@lalji_d, as per this answer by ​@cmorris on another post about this IOC feed, you cannot use it in custom rules :

You're welcome ​@desertfalcon. You are not able to use SIEM search or custom detection rules for this feed.


lalji_d
Forum|alt.badge.img+2
  • Author
  • Bronze 1
  • Answer
  • February 23, 2026

Hello ​@lalji_d, as per this answer by ​@cmorris on another post about this IOC feed, you cannot use it in custom rules :

You're welcome ​@desertfalcon. You are not able to use SIEM search or custom detection rules for this feed.

Thanks ​@chrisd2 !


hzmndt
Staff
Forum|alt.badge.img+12
  • Staff
  • September 14, 2026

Update on the latest release:

https://docs.cloud.google.com/chronicle/docs/release-notes#September_14_2026
 

September 14, 2026

Deprecated

MANDIANT_ACTIVE_BREACH_IOC,MANDIANT_FUSION_IOC, andOPEN_SOURCE_INTEL_IOC` feeds are being removed

The MANDIANT_ACTIVE_BREACH_IOCMANDIANT_FUSION_IOC, and OPEN_SOURCE_INTEL_IOC feeds are deprecated in favor of the GTI_IOC feed. After March 18, 2027, we will be removing the MANDIANT_ACTIVE_BREACH_IOCMANDIANT_FUSION_IOC, and OPEN_SOURCE_INTEL_IOC feeds. For more information on how to migrate, see Migrate Mandiant legacy feeds to GTI.


chrisd2
Forum|alt.badge.img+9
  • Bronze 5
  • September 21, 2026

Hello ​@hzmndt ,

Thanks for the heads up !

Will this make former  MANDIANT_ACTIVE_BREACH_IOC IOCs available in Custom Rules via the new GTI_IOC feed ?


hzmndt
Staff
Forum|alt.badge.img+12
  • Staff
  • September 21, 2026

@chrisd2 yes, sample syntax below:

$gti.graph.metadata.product_name = "GTI_IOC"

 $gti.graph.metadata.ati_prioritization.active_ir = true